Investigating missing projects

Incident Report for HappyCo

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 00:08 UTC

Monitoring

This incident has been resolved and we're monitoring.
Posted Jul 20, 2026 - 19:40 UTC

Investigating

We are currently investigating reports of projects not being visible.
Posted Jul 20, 2026 - 19:29 UTC
This incident affected: Management Portal and Report Access.