Increased Application Errors within Happy Property

Incident Report for HappyCo

Resolved

We've confirmed this incident is resolved.
Posted Jul 20, 2026 - 16:49 UTC

Monitoring

We've applied a fix that looks to have resolved application errors and are currently monitoring
Posted Jul 20, 2026 - 16:15 UTC

Investigating

We are seeing elevated errors and are investigating
Posted Jul 20, 2026 - 16:02 UTC
This incident affected: Management Portal and Report Access.